Peter's z80.eu site blog
Search 

My Yodobashi (Microvoice) Formula-1, with build-in eprom programmer 
Saturday, July 27, 2019, 10:25 PM
Posted by Administrator
This is a *very* nice portable CP/M computer, really rare and perhaps unknown for many, but still worth to be mentioned. It has a Z80 CPU running at 4 MHz, has a build-in eprom programmer (up to 27128) and, like many other CP/M computer, 64KB RAM. It has two 40 track double sided floppy drives (~ 346KB capacity + system tracks), and it has even an external connector for 8 inch floppy drives (the standard IBM format with 77 tracks is used).

Also, it has an integrated thermo paper printer (no chance to get such thermo paper rolls anymore).
Although it's screen is only 5.5" sized, it has a really clear and crisp display:

3 comments ( 12 views )   |  permalink   |  related link   |   ( 3.1 / 628 )
Bondwell 8T and the Expanded Memory Mystery 
Thursday, July 11, 2019, 11:30 PM
Posted by Administrator
Recently I got also a Bondwell 8T, which is an early PC/XT compatible Laptop (with LCD display, but still heavy). It has a nice keyboard, and I got also an external floppy drive (Model 112B) for it.

This laptop has a special unique feature, it has a chipset, which make it possible to use the rest of the physically existing 1024KB RAM above the 640KB limit.
Unfortunately you will NOT find the specific Expanded Memory Manager driver while using Google, so I tried several other solutions, Quarterdecks QRAM included. Nothing worked.
But I found a photo from the same laptop in a forum, and I asked the one who posted it.
Finally I got the driver, and guess what name it has ... it's always the same filename for all machines, but the program file differs always, too (because of the different hardware) - EMM.SYS. If you do not have this specific one, you can't use the extra memory, which is very important if you don't have a hard drive (this laptop didn't had one).
But if you have the driver, all goes positive, and I was even able to load a RAM-Disk driver:

I had to use TURBODSK 2.2, because RAMDRIVE.SYS does NOT support expanded memory or if you're lucky and got the last version (from MS-DOS 4.01), an AT-machine (286) is minimal required.

Also, I tested the ability to display graphics, not too bad but NO COLORS, so a dithered picture is necessary - see here:

The specific EMM driver can be downloaded here, see "related link".
add comment ( 4 views )   |  permalink   |  related link   |   ( 3 / 616 )
Gaby's CP/M Forum will move... 
Tuesday, June 18, 2019, 10:00 PM
Posted by Administrator
... so be sure to visit the new URL http://www.forumcpm.gaby.de/index.php .
Although it's german I am sure also english speaker can write entries and will get an answer in english for sure, if necessary.
Her old forum will be converted into a static web page.
add comment ( 5 views )   |  permalink   |  related link   |   ( 3.1 / 572 )
The truth about LS-120 (aka SuperDisk) media (all of them are preformatted...) 
Sunday, May 26, 2019, 09:00 PM
Posted by Administrator
Years before I bought a "SuperDisk" drive (USB) for the older Power Macintosh series. I got it with a Macintosh formatted medium.
A few month before I got an Matsushita / Panasonic ATAPI LS-120 drive. I tried to use it together with a SATA-to-IDE adapter in my modern Intel i7-4770K PC running Windows 7.
Unfortunately the drive was only recognized by Windows 7 if a disk was inserted (doesn't matter if it's a HD floppy disk or a LS-120 disk).
Because my modern PC mainboard does not have a parallel ATA connector, I tried to find an other solution, but my spare part PCI IDE RAID controller didn't helped.
Later on, I learned it MUST have an ATAPI bios, not an IDE/RAID BIOS. What bad luck the IDE RAID controller did not have a flash memory (instead, a ROM).
So I had to buy a PCI ATAPI controller (it has a ITE8212 chipset), which had the correct BIOS right from the beginning. And voilĂ , Windows 7 *does* recognize the drive even without an inserted medium.

Now I was able to use the drive without any problems ... I thought.
Also on the sticker it says "Do Not Reformat"... no solution for that ?


Reformatting the preformatted Macintosh LS-120 disk did NOT work with Windows 7.
But there must be a way to get it reformatted, also because I've seen there is a special formatter software existing.
Unfortunately again the at least 15 years old software I found does NOT work with a Windows x64 version.

Meanwhile I bought also IBM PC preformatted LS-120 disks, they worked without any problems and showed 120MB free (if empty, not used before). But I was still not able to use the Macintosh preformatted disk.

But after I got a rare LS-120 disk drive for my Thinkpad A30p, which still runs Windows XP SP3, I was able to use the above mentioned formatter software. And NOW I was able to reformat it for PC usage. It does not really "low level format" the disk, but it writes a new logical structure to the disk, without checking the format it had before.




So anybody who claims to be able to format LS-120 disks on a x64 Windows just talk bullshit. Windows always check the format before formatting is started. Macintosh preformatted disks are not recognized so you cannot format them in a different format (from Mac to PC).

add comment ( 10 views )   |  permalink   |  related link   |   ( 3.1 / 487 )
Micromint SB180FX resurrected ... and it's running well 
Sunday, May 19, 2019, 10:00 PM
Posted by Administrator
After I got some CP/M machines last year, I had no time to check and test them.
I swapped the Portable CP/M machine already against 2 Microprofessor MPF-1, and the TCS Genie IIIS didn't work (a bit oxidized socketed ICs on the mainboard could be the reason).
But I had luck, my fastest CP/M machine ever worked !!!
First, I checked the power suppy, but I didn't found anything unusual or defect.
Then I checked my WYSE WY-60 terminal, because the Micromint does not have a build-in video interface (except the GT180 card, but which is not used for operating system command in- and output). After I rediscovered how to get into the SETUP of the terminal (Shift-Select did it!), I got it tested with a loopback connector (pin 2-3 4-5 and 6-20 connected), and it worked.
Now I plugged the power cable and also the RS232 cable for the terminal connection, and voilĂ , it runs (exception: BDOS-Error on Drive B ... not sure about it yet):


P.S.: It's really fast, but I expected this already from a 9.2MHz Z80-compatible system.
It has 2304KB RAM in total, and can make use of all RAM. Also, there is a build-in SCSI controller (NCR-chip), and I have also a XEROX SCSI HDD for it, but not yet tested.

The 'related link' points to an overview of all available software disks.
add comment ( 11 views )   |  permalink   |  related link   |   ( 3 / 711 )

<Back | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | Next> Last>>